KnowledgeBase | PC3K6 | Troubleshooting


Sustain Pedal is not Working

Question:
My PC3's sustain pedal is no longer functioning. How can I correct that?

Answer:

Probably a simple fix.

First, power off your unit and verify that the pedal you are attempting to use is plugged into the jack marked "Switch Pedal 1" (Sustain) and NOT into "CC Pedal1". Once this is verified, turn the unit on. Do NOT step on the pedal while it boots up.

Try the pedal again. If things are still not operational, next go into the MIDI XMIT page. Press MIDI, then [XMIT ].

Verify that the ControlSetup parameter (top of the screen) is set to "126 Internal Voices". This item is the very thing that determines what all of your sliders, pedals, buttons, wheels, etc. do while outside of Setup mode.

If changing the ControlSetup back to 126 does not help (or if it is already on 126) then next try doing a Hard Reset (press MASTER/Page2/Reset). This will clear all the user RAM and put the machine back to factory defaults so be sure to back up any custom data to xD or USB before proceeding. At that point any settings changed on the unit will be back to "new" condition.

Short of something being physically broken, you should now have sustain functionality back. If not, the next test would be to borrow/purchase another switch type pedal as a comparison. Pedals fail far more often than jacks do. If a second, known-working pedal also fails to operate, following the above guidelines, then the unit may have a problem and will need service to rectify it.

If you feel you need service, please feel free to visit our on-line service center look up database to help locate an authorized KMS service center near you.


Need more info? Check out the following links: